Back to overview
Downtime
Site is down
Jun 17 at 06:43am UTC
Affected services
stargateuniverse.net
Updated
Jun 17 at 06:46am UTC
Just kidding there really is downtime
Affected services
Updated
Jun 17 at 06:45am UTC
Issue is resolved. Site will still be down
Affected services
Updated
Jun 17 at 06:45am UTC
We found out that this will last very very long time.
Affected services
Created
Jun 17 at 06:43am UTC
Don't worry we have not yet opened our site.
Affected services